We've confirmed that NCG requires at least Ruby 1.8.6, and won't work under Ruby 1.8.5 or earlier. When we released NCG, last week, we weren't sure of this; we had done all of our development under Ruby 1.8.6, but hadn't yet tested it under any other version of Ruby, and said as much in the "REQUIREMENTS" file in the release. This shouldn't be a big obstacle, since Ruby 1.8.6 has been out for about two years, is generally considered stable, and is the "standard" Ruby version on many platforms.
Yesterday, Bob Sutterfield (who I highly recommend, by the way, if you need a senior IT manager who really understands infrastructure; we've worked closely together in the past, and he's great at building and running high-performance IT infrastructure teams) tried to install NCG on a "Rails all-in-one-trial" server image [login required] from RightScale, running on Amazon EC2. For some reason, this RightScale server image still includes Ruby 1.8.5, despite the fact that Ruby 1.8.6 has been out for two years now. He discovered that NCG depends upon Ruby methods that were added in Ruby 1.8.6, and don't exist in Ruby 1.8.5.
We fully intend for NCG to work under versions of Ruby after 1.8.6, though we haven't tested under any of them yet. In particular, we intend for NCG to work under Ruby 1.9, and will take any necessary steps to make that happen. (For what it's worth, Ruby 1.9 just had its "first stable release" (Ruby 1.9.1) about 3 months ago.)
We'll be updating the "REQUIREMENTS" file in our next release, to reflect this new information.